Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4076 - Netscape can't launch with JavaScript set
Summary: Netscape can't launch with JavaScript set
Keywords:
Status: CLOSED DUPLICATE of bug 3514
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netscape
Version: 6.0
Hardware: sparc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-16 15:37 UTC by Stephen P. Cohen
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-28 22:55:10 UTC


Attachments (Terms of Use)

Description Stephen P. Cohen 1999-07-16 15:37:26 UTC
Netscape will abort a launch attempt if it has been
previously closed with Edit Preference Java Script
selected.  It crashes (without a core dump) with 'Illegal
Instruction' message.

If the .netscape directory is deleted from your home
directory, Netscape will launch correctly.  Exit (or close)
Netscape - you'll not be able to launch again until
the .netscape directory is deleted.

However, if after it launches the Edit Preferences Java
Script option is de-selected, Netscape can then be closed
and launched correctly.

Once launched, if the Edit Preferences Java Script is re-
selected, Netscape will crash when the Edit Preferences
window is closed.

This process is repeatable on my SunSPARCstation IPX with
64Mb memory, Weitek chip, and Sun 8 bit frame buffer color
monitor.

Comment 1 Stephen P. Cohen 1999-07-16 15:52:59 UTC
FYI.  Three commands were entered prior to running the events
described in this report.  They were:

chkfontpath --add /usr/X11R6/lib/X11/fonts/75dpi
chkfontpath --remove /usr/X11R6/lib/X11/fonts/100dpi
/etc/rc.d/init.d/xfs restart

Comment 2 Stephen P. Cohen 1999-07-16 15:54:59 UTC
Several components were upgraded prior to running the events
described in this report.  They include

kernel to 2.2.5-22
XFree stuff upgraded from -49 to -52 as found on rh errata pages.

Comment 3 Bill Nottingham 1999-07-16 16:37:59 UTC
Unable to replicate on Ultra5 or Sparc10.
Able to replicate (somewhat; it never actually starts)
on an IPX. (with 14M memory. This took a while to test. ;) )

I'd say that sparc netscape has sun4c problems. :(

I'll report it to netscape, although since they seem to
have forgotten to release a 4.6 or 4.61 for sparc, I'm
not sure how concerned they are about fixing it.

Comment 4 Stephen P. Cohen 1999-07-16 16:46:59 UTC
Make certain you're launching netscape-communicator.  netscape-
navigator 'just sits there' as you say.  Remember to launch
communicator after having deleted the .netscape directory.

Comment 5 Bill Nottingham 1999-07-16 17:07:59 UTC
Nope -
netscape-communicator SIGILLs immediately, regardless of the
state of the ~/.netscape directory.
netscape-navigator sits spinning after its dns-helper process
SIGILLs.

Comment 6 Stephen P. Cohen 1999-07-16 18:35:59 UTC
Some success was seen in launching with the following options:

netscape-communicator -noinstall -ncols 128

You might also try -ncols 4 or some very low number.

Also, I often had to re-boot the computer.  This forced the system to
launch netscape from disk rather than from system memory cache.

Another tip - try restarting xfs.

Comment 7 Bill Nottingham 1999-07-17 03:39:59 UTC
Nope, seems to be pretty much broken on all the sun4c's we have here.
DaveM, any particular reason it would blow up on sun4c and not 4m/4u?

Comment 8 Bill Nottingham 1999-07-28 22:55:59 UTC
*** This bug has been marked as a duplicate of 3514 ***


Note You need to log in before you can comment on or make changes to this bug.