Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4060 - zero-length password corrupts database
Summary: zero-length password corrupts database
Keywords:
Status: CLOSED DUPLICATE of bug 3029
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pam
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-16 00:44 UTC by tompermutt
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-02 16:16:13 UTC


Attachments (Terms of Use)

Description tompermutt 1999-07-16 00:44:49 UTC
With shadowing turned off, setting a zero-length password
seems to corrupt the password data-base.  Whether I do it by
editing /etc/passwd, or using passwd as root, the user is
unable to log on.  Furthermore, even if root runs passwd
again to set a non-null password, that user remains hosed.

Comment 1 Michael K. Johnson 1999-07-30 21:10:59 UTC
I cannot reproduce this.  Are you using NIS or some other form of
authentication besides /etc/passwd?  A non-root user cannot set a
null password with the passwd command; perhaps the old password is
still in force for you?

Comment 2 Michael K. Johnson 1999-08-02 16:14:59 UTC
OK, 3029 does look like the same report...

Comment 3 Michael K. Johnson 1999-08-02 16:16:59 UTC
The bug really does exist.  I'm not sure why I couldn't recreate it
on my machine, but plenty of people have reported it.  In any case,
it is clearly a duplicate of 3029.  Thanks for your patience...

*** This bug has been marked as a duplicate of 3029 ***


Note You need to log in before you can comment on or make changes to this bug.