Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4037 - vi command mode fails to work for bash after upgrade vs. install of 6.0
Summary: vi command mode fails to work for bash after upgrade vs. install of 6.0
Keywords:
Status: CLOSED DUPLICATE of bug 2397
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-14 18:01 UTC by lanny.t.tavasci
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-19 19:48:12 UTC


Attachments (Terms of Use)

Description lanny.t.tavasci 1999-07-14 18:01:10 UTC
I performed an upgrade from 5.1 to 6.0. After upgrade had
completed the vi command recall and line editing will not
work under bash. However, on another system that I did an
install instead of an upgrade the vi command recall and line
editing work fine. When you execute the "set -o vi" on both
systems it does set the "vi" value to "on" as seen with a
"set -o" command. However, on the upgrade system it doesn't
work, and on the fresh install system it does. The bash
fileset version is the same on both - bash-1.14.7-16.

Comment 1 lanny.t.tavasci 1999-07-31 01:50:59 UTC
Additional information: It seems that this problem is related to the
/etc/inputrc file that is installed with Red Hat 6.0. The 5.x systems
did not have that file. On systems where the vi command line editing
does not work for bash when I remove the /etc/inputrc file it fixes
the problem. I still don't know why the vi command line editing
worked on scratch installed 6.0 systems with the /etc/inputrc file in
place and not on the upgraded 5.x systems, though I have found out
recently that in some cases it didn't work for any user other than
root on a scratch installed 6.0 system. On upgraded 5.x systems it
failed to work for all users including root.

Comment 2 timw 1999-08-10 23:01:59 UTC
Please dup this bug to 2397.
Fix is comment out the assignment to 'INPUTRC' in /etc/profile.
The supplied /etc/inputrc is bogus.

Comment 3 Bill Nottingham 1999-08-19 19:48:59 UTC
*** This bug has been marked as a duplicate of 2397 ***


Note You need to log in before you can comment on or make changes to this bug.