Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4029 - pump crashes on some nonstandard kernel builds
Summary: pump crashes on some nonstandard kernel builds
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pump
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brock Organ
QA Contact:
URL:
Whiteboard:
: 4294 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-14 12:54 UTC by lofgren
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-04-25 13:07:59 UTC


Attachments (Terms of Use)

Description lofgren 1999-07-14 12:54:36 UTC
If the kernel does not have the "Packet socket" and "Socket
filtering" options enabled, pump will core dump.  I haven't
looked in the source, but I would guess it's getting an
error return from a socket() call, and the error checking is
done incorrectly or completely ignored.

dhclient does the right thing, and exits gracefully while
saying what kernel features should be present.  I would
never have made networking work without using dhclient (part
of the isc dhcp distribution), since pump wouldn't tell me
anything.

Comment 1 David Lawrence 1999-07-14 21:58:59 UTC
I have verified that compiling a kernel with the Packet Socket and
Socket Filtering options turned off, pump will dump core when trying
to initialize the network device. I have assigned this to a developer
for further review.

Comment 2 Bill Nottingham 1999-08-31 22:41:59 UTC
*** Bug 4294 has been marked as a duplicate of this bug. ***

pump dumps core when running with my own compiled
2.2.10 kernel.

I could attach the core dump, if there only was a way to
attach it.  (I guess that would qualify as a bug/enhancement
request for bugzilla).

Arieh

------- Additional Comments From jturner@redhat.com  08/02/99 08:48 -------
Submit the core dump in the same method as you would submit a patch.
Check the FAQ for the proper subject line for submitting a patch and
it will get attached to your bug automatically.

Comment 3 Jari Turkia 2000-01-09 11:30:59 UTC
After spending several hours trying to get my eth1 up with pump (DHCP via cable
modem) I found out that my packet socket (AF_PACKET) was configured as module in
kernel (tried versions 2.2.5-15 and 2.2.5-22 on RH6.0). After changing the
packet socket option to be built-in feature, pump started working.

Comment 4 Erik Troan 2000-02-03 16:00:59 UTC
Jay, please build a kernel that exhibts this problem. It should be easy enough
to fix.

Comment 5 Brock Organ 2000-04-17 21:47:59 UTC
Recompiling the kernel this way in 6.2, pump fails gracefully:

[root@localhost /root]# /sbin/pump -i eth0 --status
Operation failed.
[root@localhost /root]# uname -a
Linux localhost.localdomain 2.2.14-5.0 #1 Mon Apr 17 15:58:22 EDT 2000 i586
unknown
[root@localhost /root]#


Note You need to log in before you can comment on or make changes to this bug.