Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3978 - egcs smashes return value (in pine's mailcap.c)
Summary: egcs smashes return value (in pine's mailcap.c)
Keywords:
Status: CLOSED DUPLICATE of bug 3977
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: egcs
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL: http://www.maison-otaku.net/~loki/pat...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-10 10:35 UTC by Traub, JT
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-15 16:50:30 UTC


Attachments (Terms of Use)

Description Traub, JT 1999-07-10 10:35:05 UTC
This appears also to be part of a larger problem.  egcs
included with RedHat 6 optimizes a function in such a way
that called from certain places, the return value is
smashed.  This causes Pine to correctly report to the local
user that a file is of one MIME type, but end up attaching
it as the default for the type.  (E.g. text/* becomes
text/plain, etc.)  To reproduce this bug, compile Pine from
the SRPM on RedHat 6 with egcs-1.1.2-13 (RPM, egcs --version
shows 2.91.66).  This bug ALSO occured on a Linux 1.2.x
system using gcc-2.7.2 on RedHat 3.0.3 (just to show it's
apparently a long-standing bug).

Adding a sleep(0) call above the return in the problematic
function is a solution to this problem.  See the attached
URL.

While this should probably be fixed in PINE in the
short-term, long term it probably points to something
needing to be seen to in egcs.  IT IS WORTH NOTING THAT THIS
BUG OCCURED WITH ALL OPTIMIZATIONS OFF.  This bug has been
logged against Pine as well.

Comment 1 Traub, JT 1999-07-10 10:37:59 UTC
Pine counterpart bug is #3977

Comment 2 Cristian Gafton 1999-07-15 16:50:59 UTC
*** This bug has been marked as a duplicate of 3977 ***


Note You need to log in before you can comment on or make changes to this bug.