Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3971 - /usr/bin/gprof core dump, Redhat 6.0 Alpha.
Summary: /usr/bin/gprof core dump, Redhat 6.0 Alpha.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: binutils
Version: 6.0
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
: 3972 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-09 21:55 UTC by phil
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-30 21:23:33 UTC


Attachments (Terms of Use)

Description phil 1999-07-09 21:55:50 UTC
I have an executable that causes /usr/bin/gprof on Redhat
6.0 Alpha to give a segmentation fault and dump core, as in
  /usr/bin/gprof ep.S.1.gprof

The ep.S.1.gprof and gmon.out files are available in
 ftp://ftp.cs.arizona.edu/pub/phil.

I have mail from Ian Taylor (ian@zembu.com) which says
Jeff Law has checked in a patch to egcs which appears
to fix the problem:
 Tue Jun 29 01:37:53 1999 Jeffery A Law  (law@cygnus.com)

 * expr.c (emit_block_move): Properly handle case where one
 of the block move arguments has a queued increment or
 decrement.
 (clear_storage): Similarly.  Fix formatting goof.

Let me know if i can provide additional information.

Thanks.

Phil Kaslo
phil@cs.arizona.edu

Comment 1 Jeff Johnson 1999-07-10 14:24:59 UTC
*** Bug 3972 has been marked as a duplicate of this bug. ***



the graphic profiler gprof which is part of the binutils
suite shipped with red hat 6.0 - alpha
(binutils-2.9.1.0.23-4) seg faults dumping core.



------- Additional Comments From notting@redhat.com  07/09/99 18:31 -------


*** This bug has been marked as a duplicate of 3970 ***

------- Additional Comments From dummkopf@debussy.ucsc.edu  07/09/99 19:04 -------
it seems to me that this bug is unrelated to bug 3970.

Comment 2 Jim Kingdon 1999-07-24 17:02:59 UTC
I don't see any files at ftp://ftp.cs.arizona.edu/pub/phil
I'd like to see source code as well as the profiling data.

Comment 3 Jim Kingdon 1999-07-30 21:23:59 UTC
I have verified Ian's diagnosis and have uploaded egcs-1.1.2-17
which has the fix which Ian suggests.


------- Additional Comments From   08/29/99 19:23 -------
where did you upload egcs-1.1.2-17 to? i cannot find it on the rufus
database since i want to fix the problem on my machine as well.

thanks, helmut.

Comment 4 Jim Kingdon 1999-08-30 02:26:59 UTC
Helmut:
egcs-1.1.2-19 is part of rawhide (see http://developer.redhat.com/
for general information or http://www.redhat.com/download/mirror.html
for a list of mirror sites - see the rawhide directory).

Comment 5 helmut katzgraber 1999-08-30 16:55:59 UTC
egcs-1.1.2-19 still seg faults with my code when i invoke gprof on the
alpha.

Comment 6 Jim Kingdon 1999-08-30 17:44:59 UTC
You need to recompile gprof (or get binutils-2.9.1.0.23-5).
Also bug #4395.

Comment 7 helmut katzgraber 1999-08-30 23:02:59 UTC
cannot find the binutils-2.9.1.0.23-5 on rawhide. only ...23-4. when
can i expect it to be posted there? h.

Comment 8 Jim Kingdon 1999-08-31 14:54:59 UTC
Rawhide releases happen once a week and binutils-2.9.1.0.23-5
should be in the next one.


Note You need to log in before you can comment on or make changes to this bug.