Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3968 - RFE: conflict messages are confusing if package doesn't install.
Summary: RFE: conflict messages are confusing if package doesn't install.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm
Version: 1.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-09 18:59 UTC by Jay Freeman
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2001-08-30 17:05:17 UTC


Attachments (Terms of Use)

Description Jay Freeman 1999-07-09 18:59:38 UTC
I downloaded the new rawhide updates (wrote a program to do
this a while back), and instead of installing them manually
(like i do on my main machine) I have been experimenting
with using rpm's -F to do this (and just leaving the old
files there until I had a chance to go clean them out).
Worked great for the first few upgrades, but then I started
having problems with it under the following set of
circumstances:

A) I have a package installed that I have inside a folder.
B) I have an old version of the package in the folder.
C) I have a new version of the package in the folder.

What happens is it successfully ignores the one that is
already installed, but doesn't ignore the old file.  So
when it goes and performs a conflict analysis it determines
that it is conflicting with the new one.  I can ALMOST
understand this behavior with standard installs, but not
with a -F or a -U, since neither of those will install the
old version anyway, so why perform the conflict analysis
with them.

[root@olympus RPMs]# rpm -Fhv *
package rawhide-release-1.4.2-1 (which is newer then
rawhide-release-1.4.1-1) is already installed
package tar-1.12-10.64014 (which is newer then tar-1.12-
10.64013) is already installed
file /etc/redhat-release conflicts between attemped
installs of rawhide-release-19990708-1 and rawhide-release-
1.4.1-1

(it happened with tar as well before I removed the old
copy, so it isn't just a problem with the new version
format of the redhat-release package)

Comment 1 Jeff Johnson 2001-08-30 17:05:13 UTC
The important part of this problem is the 1st message, the conflicts
are incidental, and are side effects from the fact that MD5 sums
have actually changed between new and old packages.

Changing the subject line.

Comment 2 Jeff Johnson 2002-08-07 20:09:48 UTC
This bug is old enough that the original problem
is now the defacto behavior or rpm IMHO. Yes it's still
the same behavior.


Note You need to log in before you can comment on or make changes to this bug.