Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 395621 - Crash of amarok
Summary: Crash of amarok
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: amarok
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-22 12:45 UTC by Marcela Mašláňová
Modified: 2008-03-31 11:37 UTC (History)
2 users (show)

Fixed In Version: amarok-1.4.8-1.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-31 11:37:43 UTC


Attachments (Terms of Use)
Amarok crash message (deleted)
2008-03-29 22:45 UTC, Mary Ellen Foster
no flags Details

Description Marcela Mašláňová 2007-11-22 12:45:16 UTC
Description of problem:
Amarok is crashing since F-8

Version-Release number of selected component (if applicable):
amarok-1.4.7-7.fc8

How reproducible:
Run amarok few hours (last case was 4 hours). Play and stop song, nothing
happened. After few hours amarok crash in the middle of the song.

 
Actual results:
Crashing after few hours

Expected results:
Not crashing ;-)

Additional info:
strace wasn't helping:
Xlib:  extension "SHAPE" missing on display ":0.0".
Xlib:  extension "SHAPE" missing on display ":0.0".
Xlib:  extension "SHAPE" missing on display ":0.0".
amarokapp: Fatal IO error: client killed

Comment 1 Rex Dieter 2008-01-08 19:13:36 UTC
Can you try out amarok-1.4.8, is it better/worse/same?

Comment 2 Marcela Mašláňová 2008-01-09 08:50:41 UTC
With amarok-1.4.8 it's the same. It could be caused by something else in the
system. I removed pulse-audio. 

Comment 3 Mary Ellen Foster 2008-03-29 22:44:06 UTC
I regularly get amarok crashing on start-up (it starts as part of my session).
It *may* be related to my use of
http://www.kde-apps.org/content/show.php?content=52869 ... I've been religiously
sending the backtraces to amarok when the mail window pops up, but I'm not sure
it's doing any good.

I'll attach my latest backtrace message in a second, just for kicks.

This is with 1.4.8 on Fedora 8.

Comment 4 Mary Ellen Foster 2008-03-29 22:45:49 UTC
Created attachment 299596 [details]
Amarok crash message

Comment 5 Rex Dieter 2008-03-29 22:52:18 UTC
kirocker looks neat.  

Regardless, reporting crashes (with backtrace and as verbose details as
possible) upstream to bugs.kde.org would likely yield better results, esp since
I can't reproduce here... rock solid reliable for me, for better or worse. :)

Comment 6 Marcela Mašláňová 2008-03-31 06:31:04 UTC
The crashing stops for me with amarok-1.4.8.


Note You need to log in before you can comment on or make changes to this bug.