Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3955 - invalid statements in /etc/profile.d/kde.csh
Summary: invalid statements in /etc/profile.d/kde.csh
Keywords:
Status: CLOSED DUPLICATE of bug 3686
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdesupport
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-09 03:17 UTC by eugenia
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-09 21:09:47 UTC


Attachments (Terms of Use)

Description eugenia 1999-07-09 03:17:55 UTC
there are two invalid statements in the  KDE initialization
script (csh) that break it:

1) the statment
kdepath="${KDEDIR}/bin"
should really be
set kdepath="${KDEDIR}/bin"

2) the statement
if ( echo ${PATH} | grep -q ${kdepath} ) then
should really be something like
if ( `echo ${PATH} | grep -q ${kdepath}` ) then
so that | is interpreted as pipe rather than bitwise or

Comment 1 Jeff Johnson 1999-07-09 21:09:59 UTC
*** This bug has been marked as a duplicate of 3686 ***


Note You need to log in before you can comment on or make changes to this bug.