Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3911 - Problem in kernel version support on SMP
Summary: Problem in kernel version support on SMP
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-06 08:22 UTC by fred-m
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-31 16:25:57 UTC


Attachments (Terms of Use)

Description fred-m 1999-07-06 08:22:10 UTC
When I compile an SMP kernel from the Red Hat 6.0 kernel
sources with CONFIG_MODVERSIONS, the exported kernel
symbols do not have "smp_" on the version:
% grep printk /proc/ksyms
c01165dc printk_R1b7d4074

This might be a problem with the headers, because I am also
having problems to compile modules on this machine.

These problems do not happen when I compile a 2.2.5 kernel
from the "standard" sources:
% grep printk /proc/ksyms
c01143ac printk_Rsmp_1b7d4074

Two notes:
- This one might be related to bugs 3151, 3072, etc.
- Upgrading from 5.2 didn't detect the computer as an SMP
machine, I had to install the SMP kernel later. Any chance
that this might be related to the cause?

Comment 1 Preston Brown 1999-07-12 17:09:59 UTC
Cristian, any comments on this one?

Comment 2 Pekka Savola 1999-07-13 09:43:59 UTC
I have noticed the same (rather annoying) problem with a clean RH6.0
install into a dual-P3 computer.  For example, compiling a new network
driver (manually) causes errors - if I recompiled the whole kernel it
would no doubt work:
--- [ straight from eepro100.c - leaving -DMODVERSIONS thing off is no
help]
gcc -D__SMP__ -DMODULE -D__KERNEL__ -Wall -Wstrict-prototypes -O6 -c
eepro100.c `[ -f /usr/include/linux/modversions.h ] && echo
-DMODVERSIONS`
---
[root@dstar src]# insmod eepro100.o
eepro100.o: kernel-module version mismatch
        eepro100.o was compiled for kernel version 2.2.5-22
        while this kernel is version 2.2.5-22smp.
----
[root@dstar src]# uname -r
2.2.5-22smp
----

Comment 3 Bill Nottingham 1999-08-31 16:24:59 UTC
This is fixed in the latest kernels in Raw Hide.

Comment 4 Bill Nottingham 1999-08-31 16:25:59 UTC
make that, will be fixed with kernel-2.2.12-3 in the
next Raw Hide release.


Note You need to log in before you can comment on or make changes to this bug.