Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3896 - pam-console logout isn't triggered from xdm
Summary: pam-console logout isn't triggered from xdm
Keywords:
Status: CLOSED DUPLICATE of bug 3743
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-04 21:08 UTC by sdh4
Modified: 2017-04-25 17:26 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-15 21:26:30 UTC


Attachments (Terms of Use)

Description sdh4 1999-07-04 21:08:37 UTC
If one switches the default console to xdm from gdm
under redhat 6.0, the pam-console logout actions are
not triggered properly and the ownership of /dev/dsp,
/dev/cdrom, etc. get stuck with the first user to
log in after a reboot.

When that user logs out the following message is generated
in /var/log/secure:
Jul  4 12:57:28 myhost pam_console[786]: Could not open lock
file /var/lock/console/sdh4, disallowing console access

then on the next attempted login:
Jul  4 12:57:58 myhost pam_console[872]: console file lock
already in place /var/lock/console.lock

Comment 1 Preston Brown 1999-07-15 21:26:59 UTC
*** This bug has been marked as a duplicate of 3743 ***


Note You need to log in before you can comment on or make changes to this bug.