Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3893 - X server dies regularly under RH6.0/Alpha. XFS related
Summary: X server dies regularly under RH6.0/Alpha. XFS related
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 6.0
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
: 4073 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-04 06:18 UTC by sdh4
Modified: 2007-04-18 16:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-23 18:14:30 UTC


Attachments (Terms of Use)

Description sdh4 1999-07-04 06:18:56 UTC
on a fairly regular basis under RH6.0 on the Alpha
(I am using a matrox millenium card), several things happen
simultaneously:
  - The X server refuses to open additional windows
    (any new clients just hang)
  - Already opened clients keep running and are still usable
  - The X server starts using 100% of the CPU
  - The x font server xfs dies

side bug: X refuses to start if xfs is dead

Disabling xfs and putting the font path in XF86Config
seems to help

Comment 1 Preston Brown 1999-07-06 15:32:59 UTC
Is there anything you are doing that specifically triggers the program
failures, or is it completely random in nature?  If you can come up
with a reproducible test case we can debug this, otherwise it is going
to be much more difficult.

Comment 2 sdh4 1999-07-07 02:23:59 UTC
I have an AnotherLevel configuration set which triggers the problem
100% of the time on login. Let me know to whom I should send the
tarball.

Comment 3 Preston Brown 1999-08-31 19:09:59 UTC
*** Bug 4073 has been marked as a duplicate of this bug. ***

I have an Alpha PWS600 with a Permedia 2 video card.  I
start x (gnome or kde) and it hangs.  I start an xterm or
gnome-term, I do not get a prompt and xfs dies?  When I goto
logout of gnome or kde, the system locks up.

Comment 4 Preston Brown 1999-09-23 18:14:59 UTC
the compiler has been miscompiling one of the routines the X font
server on alpha.  We have found a  workaround for the next release.


Note You need to log in before you can comment on or make changes to this bug.