Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 388961 - nspluginwrapper does not allow keyboard focus for wrapped plugins
Summary: nspluginwrapper does not allow keyboard focus for wrapped plugins
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nspluginwrapper
Version: 8
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 429378 432673 (view as bug list)
Depends On: 453393
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-17 22:31 UTC by drago01
Modified: 2008-07-17 14:56 UTC (History)
3 users (show)

Fixed In Version: nspluginwrapper-1.1.0-2.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-17 14:56:20 UTC


Attachments (Terms of Use)

Description drago01 2007-11-17 22:31:25 UTC
Description of problem:
Plugins wrapped by nspluginwrapper seem not be be able to get any text input
(while mouse works fine). I saw this with mplayerplug-in and the adobe reader
plugin.

Version-Release number of selected component (if applicable):
nspluginwrapper-0.9.91.5-12.fc8

How reproducible:
Always 


Steps to Reproduce:
try to scroll using the keyboard in adobe reader or insert text into the search
field ... input goes to firefox but not to the plugin.
Same with mplayerplug-in ... pressing f for fullscreen does not work. 
  
Actual results:
No keyboard input for plugins.

Expected results:
Plugins should get keyboard focus/input. (work when they aren't wrapped)

Comment 1 Martin Stransky 2007-11-19 13:29:49 UTC
You're right.

Comment 2 Martin Stransky 2007-12-10 12:38:09 UTC
It looks like a problem with the specified plugins, flash gets the keyboard
input properly...

Comment 3 drago01 2007-12-10 12:48:28 UTC
yes seems it only works for flash (all other plugins I tryed do not work)

Comment 4 Martin Stransky 2007-12-10 21:41:46 UTC
It's a problem with keyboard focus. If a plugin is inserted at web page, focus
is handled properly. If the plugin is the only content at the browser window,
focus remains to browser...

Comment 5 Martin Stransky 2007-12-12 11:23:40 UTC
mplayerplug-in doesn't get keyboard input even if it's unwrapped (only in
full-screen). So the only affected plugin is Adobe reader.

Comment 6 drago01 2007-12-26 11:13:57 UTC
seems that you are correct. sorry for the confusion.
no the question remains why it does not work for adobe reader..

Comment 7 drago01 2007-12-26 11:16:41 UTC
(In reply to comment #6)
> seems that you are correct. sorry for the confusion.
> no the question remains why it does not work for adobe reader..

also having adobe reader inside an iframe does not make it work (not fullscreen)

Comment 8 Martin Stransky 2008-02-25 07:59:31 UTC
*** Bug 432673 has been marked as a duplicate of this bug. ***

Comment 9 Martin Stransky 2008-04-09 15:26:30 UTC
*** Bug 429378 has been marked as a duplicate of this bug. ***

Comment 10 drago01 2008-07-05 16:27:40 UTC
This seems to be fixed upstream in 1.0 according to the changelog.

Comment 11 Martin Stransky 2008-07-17 14:56:20 UTC
Fixed in nspluginwrapper-1.1.0-2.fc9.


Note You need to log in before you can comment on or make changes to this bug.