Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 38768 - dhcp package doesn't make dhcpd.leases file
Summary: dhcp package doesn't make dhcpd.leases file
Keywords:
Status: CLOSED DUPLICATE of bug 5405
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dhcp
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-02 15:36 UTC by Ryan Weiss
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2001-05-02 15:36:26 UTC


Attachments (Terms of Use)

Description Ryan Weiss 2001-05-02 15:36:21 UTC
Running init.d/dhcpd start|stop|status gives no output, and doesn't start 
the server.  Running /usr/sbin/dhcpd kicks an error 
about /var/lib/dhcp/dhcpd.leases missing.  Doing a 
touch /var/lib/dhcp/dhcpd.leases and then kicking the server makes it work 
fine.

Reproducible: Always
Steps to Reproduce:
1.Install dhcp-2.0p15-4 rpm
2.Edit /etc/dhcpd.conf (this step doesn't make a diff)
3.run /etc/rc.d/init.d/dhcpd start|status|<nothing>

Actual Results:  see no output, and server doesn't start -broken IMHO


Expected Results:  touch /var/lib/dhcp/dhcpd.leases - try step 2 again, 
and it will work server starts running

If you run /usr/sbin/dhcpd at step 3 above, you get an error message:
Can't open lease database /var/lib/dhcp/dhcpd.leases: No such file or 
directory -- check for failed database rewrite attempt!
Please read the dhcpd.leases manual page if you.
don't know what to do about this.
exiting.

Comment 1 Ryan Weiss 2001-05-06 04:42:30 UTC

*** This bug has been marked as a duplicate of 5405 ***


Note You need to log in before you can comment on or make changes to this bug.