Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3870 - invalid C shell syntax in /etc/profile.d/kde.csh
Summary: invalid C shell syntax in /etc/profile.d/kde.csh
Keywords:
Status: CLOSED DUPLICATE of bug 3686
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdesupport
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-02 15:27 UTC by jamie
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-02 18:17:08 UTC


Attachments (Terms of Use)

Description jamie 1999-07-02 15:27:05 UTC
I just installed kdesupport-1.1.1-1 last night.  I noticed a
problem when I logged in this morning and traced it back to
/etc/profile.d/kde.csh.

Line 8:

	kdepath="${KDEDIR}/bin"

should probably be:

	set kdepath="${KDEDIR}/bin"

and line 9:

	if ( echo ${PATH} | grep -q ${kdepath} ) then

should probably be:

	if ( `echo ${PATH} | grep -q ${kdepath}` ) then

My login shell is tcsh, but logging in with the bad
/etc/profile.d/kde.csh script dumped me into bash with this
error message:

	kdepath=/usr/bin: Command not found

I'm not sure if this is a problem in other architectures
than i386.  Thanks.

Comment 1 jamie 1999-07-02 15:31:59 UTC
Sorry for the duplicate of Bug #3686 -- please ignore/delete this.

Comment 2 Jeff Johnson 1999-07-02 18:17:59 UTC
*** This bug has been marked as a duplicate of 3686 ***


Note You need to log in before you can comment on or make changes to this bug.