Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3860 - \dosutils\autoboot.bat refers to missing initrd file
Summary: \dosutils\autoboot.bat refers to missing initrd file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 2388 2424 3951 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-01 19:34 UTC by maxfield
Modified: 2008-05-01 15:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-02 18:13:08 UTC


Attachments (Terms of Use)

Description maxfield 1999-07-01 19:34:18 UTC
The initrd file listed in autoboot.bat does not exist.

there are several initrd files in the system.  I used the
initrd-l file (as translated down to dos) and it worked. It
may not be the best to use.  This needs to be fixed.

On your ftp sited, the autoboot.bat file has not changed.

Comment 1 David Lawrence 1999-07-02 18:13:59 UTC
Unfortunately this is a known problem and will be fixed in the next
release of Red Hat. Until then please instead of using the current
autoboot.bat file, type:

loadlin autoboot\vmlinuz initrd=.\autoboot\initrd.img

Comment 2 Jeff Johnson 1999-07-09 20:58:59 UTC
*** Bug 3951 has been marked as a duplicate of this bug. ***

    I've finally gotten brave enough to try RedHat 6.0 - but
the CD won't autoboot for me.

    What I had to do was create a bootable floppy with CD
driver, define the CD as drive Z (to get it out of the way
in case I had other hard drives), copy
\dosutils\autoboot.bat as rh6set.bat on the floppy and call
this from the floppy's autoexec.bat.  I then had to edit the
loadlin line of rh6set.bat to:

z:
cd dosutils
loadlin autoboot\vmlinuz initrd=autoboot\initrd.img

   initrd.img was not in the place specified in the original
autoboot.bat. There were initrdN.img files (N being numbers)
there.

Hopefully helpfully...

Dexter

Comment 3 Jeff Johnson 1999-07-09 21:00:59 UTC
*** Bug 2388 has been marked as a duplicate of this bug. ***

Current \dosutils\autoboot.bat looks like this:

loadlin autoboot\vmlinuz
initrd=..\misc\src\trees\initrd.img

This sould be initrd=autoboot\initrd.img

Anyway file ..\misc\src\trees\initrd.img does not exist.
In directory ..\misc\src\trees you now have only files
initrd-local.img and initrd-network.img.

------- Additional Comments From jbj@redhat.com  06/19/99 16:00 -------


*** Bug 3257 has been marked as a duplicate of this bug. ***

On installing after booting off the CDROM, I had found that
the AUTOBOOT.BAT INITRD.IMG is pointing to the wrong
directory. The directory it should be pointing to is as
follows:
X:\DOSUTILS\AUTOBOOT\INITRD.IMG.
(X being the cdrom drive letter).
Entering this at the root seems to run correctly.


------- Additional Comments From jbj@redhat.com  06/19/99 14:56 -------


*** Bug 3584 has been marked as a duplicate of this bug. ***

Trying to start up manually from DOS, I invoked the AUTOBOOT
script from the \DOSTOOLS directory, and LOADLIN failed to
find the appropriate kernel and ramdisk image.  Looking
around, I found apparently the only kernel and ramdisk image
on the CD, but they were in different directories than the
batch file was referencing.  Manually running loadlin with
the different paths allowed me to boot and install normally.

Comment 4 Jeff Johnson 1999-07-09 21:06:59 UTC
*** Bug 2424 has been marked as a duplicate of this bug. ***

dosutils/autoboot.bat points to:

initrd=..\misc\src\trees\initrd.img

there aint a misc\src\trees\initrd.img

there is a initrd-local.img.  I assume that is the file that
should be used.  Not sure if there is a symlink that got
omitted.

Archive mirrored from metalab.unc.edu.

------- Additional Comments From dkl@redhat.com  04/29/99 17:58 -------
I have verified this to be true.

------- Additional Comments From notting@redhat.com  04/29/99 18:55 -------


*** Bug 2418 has been marked as a duplicate of this bug. ***

in i386/dosutils/autoboot, vmlinux is a directory and
should be a file. There is a .in.vmlinuz. file...

This was from the mirror at metalab. I could not login to
the main FTP site or any other mirror to check if this is
a global problem or a mirror problem.


Note You need to log in before you can comment on or make changes to this bug.