Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3836 - permissions on /dev/ttyS0
Summary: permissions on /dev/ttyS0
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: filesystem
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-30 19:25 UTC by tom
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-13 16:46:20 UTC


Attachments (Terms of Use)

Description tom 1999-06-30 19:25:01 UTC
I upgraded from Redhat 5.2 to Redhat 6.0 amd all went well
except for an nnoying problem with the permissions on
/dev/ttyS0. The scripts for connecting via PPP (ppp-on, etc
as detailed in the PPP-HOWTO) use pppd with setuid root so
that any user may connect. The problem is that each time
pppd is run and connects it sets the permissions on
/dev/ttyS0 to rw-r-r--. No user can subsequently connect. No
matter how many times I reset the permissions, the problem
reoccurs.

Comment 1 Michael K. Johnson 1999-07-13 16:46:59 UTC
That's a feature, not a bug.  The comment above the code that does
that says:
"Do the equivalent of `mesg n' to stop broadcast messages."

If you want to change this behaviour, you may be able to put a
chmod command in your ip-up script; otherwise you will have to
recompile pppd.

Alternatively, you can set up pppd the Red Hat way as documented
in our manual, and select the option that lets any user start and
stop that ppp device.


Note You need to log in before you can comment on or make changes to this bug.