Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 383551 - hpet_late_init panic on VIA Apollo CLE266
Summary: hpet_late_init panic on VIA Apollo CLE266
Keywords:
Status: CLOSED DUPLICATE of bug 394981
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Thomas Gleixner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: K12LTSP
TreeView+ depends on / blocked
 
Reported: 2007-11-14 22:30 UTC by Warren Togami
Modified: 2008-08-02 23:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-28 20:23:45 UTC


Attachments (Terms of Use)
lspci -v (deleted)
2007-11-14 22:32 UTC, Warren Togami
no flags Details

Description Warren Togami 2007-11-14 22:30:54 UTC
kernel-2.6.23.1-42.fc8.i586
kernel-2.6.23.1-49.fc8.i586

http://www.disklessworkstations.com/cgi-bin/web/200029.html
Intermittently (10-20%) when booting this VIA based thin client, panics very
early in hpet_late_init.  nohpet seems to avoid the problem.  Other
distributions are reportedly not seeing this issue, so this might be a
relatively new kernel bug.

Comment 1 Warren Togami 2007-11-14 22:31:12 UTC
http://people.redhat.com/wtogami/temp/via-i586-hpet-panic.jpg
Photo of panic

Comment 2 Warren Togami 2007-11-14 22:32:04 UTC
Created attachment 259061 [details]
lspci -v

Comment 3 Warren Togami 2007-11-14 22:37:34 UTC
davej suggested assigning this to tglx.


Comment 4 Chuck Ebbert 2007-11-14 23:43:34 UTC
The code dump at the bottom of the page doesn't match the i586 kernel at all.

8d b4 26 00 00 00 00  is a NOP [leal 0(esi),esi]



Comment 5 Thomas Gleixner 2007-11-15 00:21:24 UTC
> davej suggested assigning this to tglx.

/me grumbles :)

Warren,

"Intermittently (10-20%) when booting this VIA based thin client, panics very
early in hpet_late_init."

Can you please provide the full boot log from one of the other (80-90%)
successful boots ?

Further it might be helpful, if you could capture the boot of a crash via serial
console.

Please add
 earlyprintk=serial,ttyS0,115200

to the kernel command line and connect the box to a second one with a null
modem cable. On the second box please capture the output of the kernel.

Thanks,

    tglx


Comment 6 Warren Togami 2007-11-15 18:22:18 UTC
I will have physical access to it again tomorrow.


Comment 7 Chuck Ebbert 2007-11-28 20:23:45 UTC
More info is available in the newer bug, including full oops captures.
Why a NOP instruction could cause a divide error is a real mystery...

*** This bug has been marked as a duplicate of 394981 ***


Note You need to log in before you can comment on or make changes to this bug.