Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3832 - /etc/profile.d/kde.csh has invalid code
Summary: /etc/profile.d/kde.csh has invalid code
Keywords:
Status: CLOSED DUPLICATE of bug 3686
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdesupport
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-30 18:28 UTC by A.J. Aranyosi
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-30 22:50:20 UTC


Attachments (Terms of Use)

Description A.J. Aranyosi 1999-06-30 18:28:21 UTC
The file /etc/profile.d/kde.csh in the updated kdesupport
package (kdesupport-1.1.1-1) contains the followine line of
sh code:
  kdepath="${KDEDIR}/bin"
which should read
  setenv kdepath "${KDEDIR}/bin"

Net result:
When a user whose default shell is csh tries to log in (or
open an xterm, etc), the script fails at this line, printing
the following message in the user's window:
 kdepath=/usr/bin: Command not found.
 kdepath: Undefined variable.
The user's .cshrc is not executed.

Comment 1 A.J. Aranyosi 1999-06-30 18:35:59 UTC
One more change:  the line
 if ( echo ${PATH} | grep -q ${kdepath} ) then
should read
if ( `echo ${PATH} | grep -q ${kdepath}` ) then

Comment 2 Jeff Johnson 1999-06-30 22:50:59 UTC
*** This bug has been marked as a duplicate of 3686 ***


Note You need to log in before you can comment on or make changes to this bug.