Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 38098 - installer crashes on testing video Cirrus Logic GD544x
Summary: installer crashes on testing video Cirrus Logic GD544x
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-27 15:57 UTC by ashworth
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2001-05-17 20:43:34 UTC


Attachments (Terms of Use)
crash file from anaconda (deleted)
2001-04-27 15:59 UTC, ashworth
no flags Details

Description ashworth 2001-04-27 15:57:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (Win98; I)


Compaq Proliant 1600. Cirrus Logic GD544x, IBM monitor.  Installed 7.1, clean, upon reboot, it's not able to go into video mode, can't see the 
login screen, it's black.  Have tried to re-install several times, last two times the installer crashed when I hit the test video button.  V7.0 worked 
fine with this same hardware config.

Reproducible: Always
Steps to Reproduce:
1. Install 7.1
2.reboot
3.no video image
	

Actual Results:  don't get a video image. appears the system is up, I can type "blind" and it appears the system is logging in, just no video 
image (it blinks a little, but that's it)

Expected Results:  Got a video image.

Noticed other bug reports.  Appears that the installer isn't setting up the X stuff correctly??

Comment 1 ashworth 2001-04-27 15:59:12 UTC
Created attachment 16665 [details]
crash file from anaconda

Comment 2 Mike A. Harris 2001-05-18 04:32:35 UTC
This is a bug XFree86 mainly.  Acceleration is broken in the Cirrus
Logic driver.  We didn't know this in advance unfortunately.  The workaround
is to manually configure XFree86 after installation instead with:

Xconfigurator --preferxf4 --nodri

Then edit the config file /etc/X11/XF86Config-4 and add a new option:

Option
"noaccel"

This should get you up and running.  The installer is fixed in rawhide to
default this driver to noaccel in the future, and there is another bug
open for this against XFree86 already.  The above workaround should work
for you.


Note You need to log in before you can comment on or make changes to this bug.