Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3805 - /etc/profile.d/kde.csh is bad csh
Summary: /etc/profile.d/kde.csh is bad csh
Keywords:
Status: CLOSED DUPLICATE of bug 3686
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdesupport
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-29 16:21 UTC by Paul Sand
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-30 22:49:28 UTC


Attachments (Terms of Use)

Description Paul Sand 1999-06-29 16:21:44 UTC
The kdesupport-1.1.1-1.i386.rpm in the updates directory
contains /etc/profile.d/kde.csh which contains csh syntax
errors. Possible fix (works for me):

# KDE initialization script (csh)
if ( $?KDEDIR ) then
         if ( $KDEDIR == "/usr" ) then
         exit
         endif
endif
setenv KDEDIR /usr
set kdepath="${KDEDIR}/bin"
echo ${PATH} | grep -q ${kdepath}
if ( $status ) then
  exit
endif

setenv PATH "${kdepath}:${PATH}"

Comment 1 Jay Turner 1999-06-29 16:59:59 UTC
This issue has been forwarded to a developer for further action.

Comment 2 Nalin Dahyabhai 1999-06-30 15:08:59 UTC
This is a duplicate of bug 3686.

Comment 3 Jeff Johnson 1999-06-30 22:49:59 UTC
*** This bug has been marked as a duplicate of 3686 ***


Note You need to log in before you can comment on or make changes to this bug.