Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3802 - rpm -V wish list
Summary: rpm -V wish list
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
: 3800 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-29 16:03 UTC by Edward Kuns
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-30 23:28:48 UTC


Attachments (Terms of Use)

Description Edward Kuns 1999-06-29 16:03:43 UTC
I use "rpm -V" to find installation problems and unexpected
changes.  A wonderful addition to help this would be:

o A new option: --notime ... Ignore files if the only change
is a changed time (ie, kernel-source .depend files)

o A new option: --nocfg ... Ignore changed files if they are
marked as configuration files.  This will help reduce output
to things that aren't expected to change.

o A new option: --nouser, or --nogrp, or something like that
to ignore changed files when the only change is user and/or
group.  Some rpm files seem to want to install files for a
given nonstandard user, but don't install that user in
/etc/passwd.  A better way to do this would be:  At install
time, don't install if the user & group don't exist.  Add an
option to force install to a named user and group.  "rpm
-Uvh --force package.rpm" would force an install to the
nonexistent user & group.  "rpm -Uvh --user=root
--group=root package.rpm" would change all non-existent user
& group while installing the package so there would be no
complaints.

Comment 1 Jay Turner 1999-06-29 17:06:59 UTC
Recommendation has ben forwarded to package developer/maintainer.

Comment 2 Jay Turner 1999-06-29 17:11:59 UTC
*** Bug 3800 has been marked as a duplicate of this bug. ***

rpm -V complains about many, many files in kernel-source and
kernel-headers once one has made a kernel.  A wonderful
enhancement would be to mark, somehow, all the files that
one expects to change in these rpm files.  For example, all
the ".depend" files.  I have pages and pages of "rpm -V"
complaints in kernel-headers and kernel-source.

I know this is normal behavior.  My wish is for some way to
mark files that one expects to change so rpm -V (perhaps
with some other option) won't list such files.  When using
the output of "rpm -Va" to look for system problems, it
would make life much much easier!

Comment 3 Jeff Johnson 2001-07-25 21:19:25 UTC
All but --nocfg are implemented in rpm-4.0.3.

FWIW, the effect of --nocfg can be trivially implemented
by doing
	rpm -Va | grep -v ' c '
and, with almost no additiona effort, can be configured
using a popt alias in /etc/popt with rpm -Va --pipe.
I see little need to add the option to rpm's default configuration.


Note You need to log in before you can comment on or make changes to this bug.