Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3801 - rpm -Vp package-version-etc.rpm doesn't work
Summary: rpm -Vp package-version-etc.rpm doesn't work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-29 15:53 UTC by Edward Kuns
Modified: 2015-01-07 23:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-30 13:50:28 UTC


Attachments (Terms of Use)

Description Edward Kuns 1999-06-29 15:53:37 UTC
If I recall correctly, I used to be able to verify against a
package file instead of against the rpm database.  "rpm -q"
returns rpm-3.0-6.0.

Here is an example:

[root@kilroy /RPMS]# rpm -Vp pump-0.6.7-1.i386.rpm
package pump-0.6.7-1.i386.rpm is not installed

(I chose pump because it's a short name and not because of
anything with that package.)

Comment 1 Jay Turner 1999-06-29 17:08:59 UTC
Confirmed in test lab.  Looks like this command should work according
to the man page.

Comment 2 Jeff Johnson 1999-06-30 13:50:59 UTC
This has been fixed in later versions or rpm. Use the pre-release
version of rpm-3.0.2 in Raw Hide (ftp://rawhide.redhat.com) or
the released rpm-3.0.1-12* from ftp.rpm.org.


Note You need to log in before you can comment on or make changes to this bug.