Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 378 - minimal vi doesn't have /usr/bin/vi so crontab -e fails
Summary: minimal vi doesn't have /usr/bin/vi so crontab -e fails
Keywords:
Status: CLOSED DUPLICATE of bug 120
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-10 08:54 UTC by simon.mudd
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-12-10 15:50:20 UTC


Attachments (Terms of Use)

Description simon.mudd 1998-12-10 08:54:47 UTC
on a fresh install of redhat 5.2/intel

I have the following packages installed on a new 5.2 box.

[root@mail2 bin]# rpm -qa | egrep '(cron|vi)'
crontabs-1.7-3
tetex-dvilj-0.9-6
tetex-dvips-0.9-6
tetex-xdvi-0.9-6
vim-common-5.3-3
vim-minimal-5.3-3
vixie-cron-3.0.1-26

Note: when using crontab -e I get the following error:
[root@mail2 bin]# crontab -e
/bin/sh: /usr/bin/vi: No such file or directory
crontab: "/usr/bin/vi" exited with status 126
[root@mail2 bin]# rpm -ql vim-minimal
/bin/ex
/bin/rvi
/bin/rview
/bin/vi
/bin/view
[root@mail2 bin]#


Note: vi has been put in /bin, and crontab expects it in
/usr/bin

Simon

Comment 1 Jay Turner 1998-12-10 14:13:59 UTC
I need more information from you about the specific packages that you
installed besides the ones for cron and vi.  For example, did you do a
workstation install, or a custom, and if so, which packages did you
select.  In test lab I was unable to replicate your problem, as in
fresh install there was a symbolic link from /usr/bin/vi to /bin/vi.

Comment 2 Bill Nottingham 1998-12-10 15:50:59 UTC
*** This bug has been marked as a duplicate of 120 ***


Note You need to log in before you can comment on or make changes to this bug.