Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3757 - /etc/profile.d/kde.csh screwed up in updated package
Summary: /etc/profile.d/kde.csh screwed up in updated package
Keywords:
Status: CLOSED DUPLICATE of bug 3686
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdesupport
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-27 05:20 UTC by hugues.talbot
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-29 15:45:29 UTC


Attachments (Terms of Use)

Description hugues.talbot 1999-06-27 05:20:41 UTC
updated package kdesupport-1.1.1-1.i386.rpm from June 24th
has a trivial bug in /etc/profile.d/kde.csh, it contains
the line:

kdepath="${KDEDIR}/bin"


Of cource tcsh or csh are unable to parse this. The result
is that anyone using csh or tcsh as their default shell
will see this upon  login:

===============================================
Last login: Sun Jun 27 14:53:32 1999 from
talbot.home.nsw.cmis.csiro.au
No mail.
kdepath=/usr/bin: Command not found.
kdepath: Undefined variable.
[talbot@mascot ~]$

================================================

The user's .login and .cshrc files are ignored. This
is hard to trace and infuriating.... To compensate, the
fix is rather obvious.

It took me aaages to find the bug and I really hated
the packaged maintainer for a few minutes, but eh,
that's life.

Thanks for the free software and keep up the good work.

Comment 1 Jay Turner 1999-06-28 13:31:59 UTC
This issue has been forwarded to a developer for further action.

Comment 2 Derek Tattersall 1999-06-29 15:45:59 UTC
*** This bug has been marked as a duplicate of 3686 ***


Note You need to log in before you can comment on or make changes to this bug.