Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 375481 - NetworkManager should not assume all links are DHCP enabled
Summary: NetworkManager should not assume all links are DHCP enabled
Keywords:
Status: CLOSED DUPLICATE of bug 134886
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 8
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-11 05:13 UTC by Tim Taiwanese Liim
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-13 17:02:42 UTC


Attachments (Terms of Use)

Description Tim Taiwanese Liim 2007-11-11 05:13:28 UTC
Description of problem:
    NetworkManager starts DHCP client for all types of interfaces,
    even for those with static IP address.  This is very bad for
    servers, where static IP is much desired, and NetworkManager
    really helps to maintain network connectivity.

    Related to bug374861, issue #1
       1.  Network Manager will not connect using STATIC ip addressing.

Version-Release number of selected component (if applicable):
    NetworkManager-0.7.0-0.5.svn3030.fc8


How reproducible:
    always.

Steps to Reproduce:
1. ifconfig eth0 down
2. NetworkManager --no-daemon
3. ifconfig eth0 192.168.47.228 up
  
Actual results:
    NetworkManager starts dhclient and changes eth0 IP.

Expected results:
    eth0 should keep the static IP address as assigned
    by "ifconfig eth0 192.168.47.228 up".

Additional info:
    work around for servers that requires static IP:
    disable NetworkManager, by using system-config-services.

Comment 1 Dan Williams 2007-11-13 17:02:42 UTC

*** This bug has been marked as a duplicate of 134886 ***


Note You need to log in before you can comment on or make changes to this bug.