Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3750 - laptop keyboard does not work
Summary: laptop keyboard does not work
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gpm
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
: 2276 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-26 20:09 UTC by brandon
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-25 03:07:05 UTC


Attachments (Terms of Use)

Description brandon 1999-06-26 20:09:57 UTC
I just installed RH6 from the network, but the install went
fine--I skipped X (wanting to configure it later), and when
it rebooted it came up to the login: prompt but does not
accept keyboard input.  lilo: and booting single-user will
accept keyboard input.  This is on a brand new Toshiba Tecra
8000.

Comment 1 Derek Tattersall 1999-06-28 13:53:59 UTC
Could this have something to do with a mistakenly configured keyboard?

Comment 2 brandon 1999-06-30 14:41:59 UTC
If it is mistakenly configured, it is by the redhat install, all I
have done is install and reboot--and the keyboard doesn't work.

Comment 3 jflythe 1999-07-09 16:20:59 UTC
I too have experienced this With my Toshiba Tecra 8000. I just
created a new bootable Red Hat install CD from files that I dl'ed
from a mirror site. The install works well on a IBM 300PL, but the
keyboard does not work after I install using the new CD on my Tecra.
The Red Hat CD that I created contains all of latest updated RPMS

Comment 4 jflythe 1999-07-09 22:24:59 UTC
I think that it has to do with the updated modules, and not the
installation. I can install the original RH 6.0 distribution, with no
errors, and the keyboard works fine.

Comment 5 Cristian Gafton 1999-07-28 06:21:59 UTC
*** Bug 2276 has been marked as a duplicate of this bug. ***

It's usually around the httpd server -- and it totally
stops working, though the machine is still okay.  I
can't even use the SysRq stuff.  Usually wind up
having to power-down if I'm not on the network.
NOTE: The keyboard *usually* works if I load XDM.
NOTE: This is true for both Rawhide and 5.9, but
it worked fine under 5.2 and prior revs.  I did a
disk wipe before installing 5.9, so I don't think
it was anything residual from the Rawhide install.

Comment 6 Cristian Gafton 1999-07-28 07:12:59 UTC
assigned to dledford, Cc:ed Alan on it.

Comment 7 Anonymous 1999-08-11 16:47:59 UTC
I just ran into this installing RH6 (from a Cheapbytes CD) onto a
friends' Toshiba Satellite 4080CDT. The install went fine (other than
not having a valid X server), but didn't respond to the keyboard when
we got as far as the login: prompt. I'd already booted the system from
a tom's root/boot disk so I knew it worked in some situations. I
rebooted in single user mode and things worked Ok. Following a hunch,
I stopped gpm from coming up by setting MOUSETYPE="none" in
/etc/sysconfig/mouse and that cleared it.

The installer had probed the mouse as being a PS/2 mouse on
/dev/psaux; I don't know whether that's correct or not at the moment,
but it looks like gpm tries to do something with the mouse and/or the
keyboard which causes both to lock up.


------- Additional Comments From   09/23/99 13:23 -------
Hy,
 I also have a T8000, installed RH6 like a charm and...keyboard
locked at the login prompt !
Solution : in /etc/inittab replace the first mingetty by getty
Next have to reconfigure the terminal to be Linux...

Maybe try to have a new version of mingetty and recompile it.

Hope this helps !
Cedric Brossard
Mailto:cedric.brossard@NCR.com

Comment 8 Bill Nottingham 1999-09-25 03:07:59 UTC
Turning off gpm should solve the problem. It's hardware weirdness.


Note You need to log in before you can comment on or make changes to this bug.