Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3719 - /bin/mail segfault while reading message with NUL
Summary: /bin/mail segfault while reading message with NUL
Keywords:
Status: CLOSED DUPLICATE of bug 8100
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mailx
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-24 22:32 UTC by mob
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-03 16:07:32 UTC


Attachments (Terms of Use)

Description mob 1999-06-24 22:32:55 UTC
/bin/mail crashes with a Segmentation fault when reading a
mail file with a NULL character.

Comment 1 Jay Turner 1999-06-28 15:16:59 UTC
This issue has been forwarded to a developer for further action.

Comment 2 Jeff Trawick 2000-01-02 20:22:59 UTC
See bug 8100.  This has a fix for at least one case where there is a binary
zero in the mail text.  I didn't notice this bug or 6859 when I submitted the
report for 8100.  Sorry!

Comment 3 Bill Nottingham 2000-01-03 16:07:59 UTC
*** This bug has been marked as a duplicate of 8100 ***


Note You need to log in before you can comment on or make changes to this bug.