Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3718 - /etc/profile.d/kde.csh has syntax errors under tcsh
Summary: /etc/profile.d/kde.csh has syntax errors under tcsh
Keywords:
Status: CLOSED DUPLICATE of bug 3686
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdesupport
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 3709 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-24 22:17 UTC by khera
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-25 10:32:41 UTC


Attachments (Terms of Use)

Description khera 1999-06-24 22:17:29 UTC
I upgraded to the kde 1.1.1 release posted to
updates.redhat.com, and the next time I logged in, there was
a syntax error reported prior to my .login or .cshrc being
run.  I tracked this down to syntax errors (at least under
tcsh) in /etc/profile.d/kde.csh.  According to the csh
manual, these fixes should be there as well (ie, you can't
use a pipeline inside an if() statement).

--- kde.csh.orig        Mon Jun 21 14:28:21 1999
+++ kde.csh     Thu Jun 24 18:11:08 1999
@@ -5,8 +5,9 @@
          endif
 endif
 setenv KDEDIR /usr
-kdepath="${KDEDIR}/bin"
-if ( echo ${PATH} | grep -q ${kdepath} ) then
+set kdepath="${KDEDIR}/bin"
+echo "${PATH}" | grep -q ${kdepath}
+if ( ! $status ) then
   exit
 endif

Comment 1 Jeff Johnson 1999-06-25 10:28:59 UTC
*** Bug 3709 has been marked as a duplicate of this bug. ***

The following bug(s) cause an error every time a user tries
to login or execute a shell, if their default shell is
csh/tcsh.  It also halts processing of the user's own
customization files.

The 8th line in /etc/profile.d/kde.csh says:

  kdepath="${KDEDIR}/bin"

Because this is for csh, not sh, it should read:

  set kdepath="${KDEDIR}/bin"

Also, lines 10 through 12 that read:

  if ( echo ${PATH} | grep -q ${kdepath} ) then
    exit
  endif

should read

  echo $PATH | grep -q $kdepath && exit

Comment 2 Jeff Johnson 1999-06-25 10:32:59 UTC
*** This bug has been marked as a duplicate of 3686 ***


Note You need to log in before you can comment on or make changes to this bug.