Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3709 - Bug in new /etc/profile.d/kde.csh from kdesupport-1.1.1-1
Summary: Bug in new /etc/profile.d/kde.csh from kdesupport-1.1.1-1
Keywords:
Status: CLOSED DUPLICATE of bug 3718
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdesupport
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-24 19:08 UTC by Raul Acevedo
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-25 10:28:35 UTC


Attachments (Terms of Use)

Description Raul Acevedo 1999-06-24 19:08:09 UTC
The following bug(s) cause an error every time a user tries
to login or execute a shell, if their default shell is
csh/tcsh.  It also halts processing of the user's own
customization files.

The 8th line in /etc/profile.d/kde.csh says:

  kdepath="${KDEDIR}/bin"

Because this is for csh, not sh, it should read:

  set kdepath="${KDEDIR}/bin"

Also, lines 10 through 12 that read:

  if ( echo ${PATH} | grep -q ${kdepath} ) then
    exit
  endif

should read

  echo $PATH | grep -q $kdepath && exit

Comment 1 Jeff Johnson 1999-06-25 10:28:59 UTC
*** This bug has been marked as a duplicate of 3718 ***


Note You need to log in before you can comment on or make changes to this bug.