Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 369771 - GFS2: bring RHEL gfs2_edit up to date
Summary: GFS2: bring RHEL gfs2_edit up to date
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs2-utils
Version: 5.1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Chris Feist
QA Contact: GFS Bugs
URL:
Whiteboard:
: 235931 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-07 15:27 UTC by Robert Peterson
Modified: 2010-01-12 03:40 UTC (History)
1 user (show)

Fixed In Version: RHBA-2008-0350
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-21 17:20:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch to fix the problem (deleted)
2007-11-16 19:41 UTC, Robert Peterson
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0350 normal SHIPPED_LIVE gfs2-utils bug fix update 2008-05-20 12:44:56 UTC

Description Robert Peterson 2007-11-07 15:27:56 UTC
Description of problem:
I've fixed a lot of bugs in gfs2_edit and added many improvements
over the past several months.  Before I began, I offered Rob Kenna a
choice of whether to open and process a whole lot of bugzilla
records to fix every issue (which is a lot of management overhead)
or whether to open one bug record to play catchup.  He opted for
the latter.  (Kevin was on vacation or something at the time).
So this bug is for integrating the latest changes to gfs2_edit into
RHEL5's gfs2-utils.

Version-Release number of selected component (if applicable):
RHEL5

Additional info:
Improvements to gfs2_edit include:

1. Allow gfs2_edit "savemeta" option to save journal metadata records
   and other system files such as statfs.
2. Implement rgcount option.
3. Implement rgflags option to set flags (like NO_ALLOC).
4. Implement -p rg X (to print rg X).
5. Ability to print gfs2 journal breakdown.
6. Ability to print gfs1 journal breakdown.
7. Ability to jump to relative block number (e.g. enter "+0x134" for
   block number to have it jump to the current block number + 0x134.)
8. Ability to print/show recurse when printing/showing indirect blocks
   associated with an inode.
9. Bug fixes.

Comment 1 Robert Peterson 2007-11-07 16:23:25 UTC
Requesting ACK flags for inclusion into RHEL5.2.


Comment 2 RHEL Product and Program Management 2007-11-07 16:24:52 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Robert Peterson 2007-11-16 19:22:17 UTC
More:

10. Better handling of extended attribute blocks (savemeta, printing, etc).
11. Ability to recognize print quota change blocks.
12. Ability to recognize log buffer blocks.
13. Ability to recurse directories that are indirect.
14. Fixed a bunch more bugs, mostly to do with extended mode.


Comment 4 Robert Peterson 2007-11-16 19:41:24 UTC
Created attachment 261741 [details]
Patch to fix the problem

I always like to attach the patch.  :7)

Comment 5 Robert Peterson 2007-11-16 19:44:49 UTC
Patch was tested on system roth-01.  It was committed to the RHEL5
branch of CVS.  The only difference now between the HEAD and RHEL5
versions is the version string.  Changing status to Modified.


Comment 6 Robert Peterson 2007-12-12 20:46:13 UTC
*** Bug 235931 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2008-05-21 17:20:28 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0350.html



Note You need to log in before you can comment on or make changes to this bug.