Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3684 - kdesupport-1.1.1-1 has broken /etc/profile.d/kde.csh
Summary: kdesupport-1.1.1-1 has broken /etc/profile.d/kde.csh
Keywords:
Status: CLOSED DUPLICATE of bug 3686
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdeutils
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-23 20:46 UTC by chris
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-23 21:01:45 UTC


Attachments (Terms of Use)

Description chris 1999-06-23 20:46:30 UTC
Someone mixed up sh and csh syntax in
/etc/profile.d/kde.csh.  It breaks csh/tcsh logins horribly
(no user login scripts are executed!!).  Patch follows:
write me if this wordwraps horribly:

--- /etc/profile.d/kde.csh.orig Mon Jun 21 14:28:21 1999
+++ /etc/profile.d/kde.csh      Wed Jun 23 15:15:46 1999
@@ -5,9 +5,7 @@
          endif
 endif
 setenv KDEDIR /usr
-kdepath="${KDEDIR}/bin"
-if ( echo ${PATH} | grep -q ${kdepath} ) then
-  exit
-endif
+set kdepath="${KDEDIR}/bin"
+if ( `echo ${PATH} | grep -q ${kdepath} | wc -l` != 0 )
exit

Comment 1 Bill Nottingham 1999-06-23 21:01:59 UTC
*** This bug has been marked as a duplicate of 3686 ***


Note You need to log in before you can comment on or make changes to this bug.