Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3670 - Jobs on a Dual processor machine only use 50% of 1 CPU!!
Summary: Jobs on a Dual processor machine only use 50% of 1 CPU!!
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-23 14:18 UTC by feldman
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-09 01:11:34 UTC


Attachments (Terms of Use)

Description feldman 1999-06-23 14:18:00 UTC
We are using an Asus P2B-D motherboard with two Pentium II
processors installed on it, and have installed RedHat 6.0
The SMP kernel is loaded by default and the two processors
seem to be detected.

However, when running a job, "top" reports only 50% CPU
usage and takes twice as long as it did beforehand.
If 2 jobs are run simultaneously, both take 50% and if 3 or
more are run, they begin to slow down each other further, so
it looks like only 1 processor is beign used, and a maximum
of 50% being allocated to any one task.

The majority of all kernel and motherboard settings are at
their
defaults except for simple things like drive settings and so
on.

Comment 1 Jay Turner 1999-06-23 15:16:59 UTC
This issue has been forwarded to a developer for further review.

Comment 2 feldman 1999-06-25 13:46:59 UTC
It appears this is not actually a bug but a "feature".  The 50% seems
to imply 50% of both CPUS and the CPU time acts as if both CPUs were
just 1 cpu, so a job that takes 1 processor 2 minutes of real time
takes 1 minute of "CPU" time at 50%.  So I guess this is not a bug.

Comment 3 Cristian Gafton 1999-07-09 01:11:59 UTC
Normal operation.


Note You need to log in before you can comment on or make changes to this bug.