Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 366 - Shadow passwd command not included with shadow-utils
Summary: Shadow passwd command not included with shadow-utils
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: distribution
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-09 18:54 UTC by deana
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-12-09 20:20:19 UTC


Attachments (Terms of Use)

Description deana 1998-12-09 18:54:03 UTC
It seems the shadow utils RPM does not replace the passwd
command.  When you install the shadow utils and run pwconv,
you cannot change passwords with passwd anymore and get
passwd: Critical Error.  I solved the problem by getting the
current Shadow suite and installing it, which included the
shadow passwd program.

Comment 1 David Lawrence 1998-12-09 20:20:59 UTC
Unable to reproduce this problem.  Since Red Hat Linux uses PAM, it
bypasses the shadow utilities in updating the password database.  When
you replaced the shadow utilities, you wiped out the PAM authenication
on login and other things.


Note You need to log in before you can comment on or make changes to this bug.