Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 365651 - TAHI--DHCPv6--The check of IA options of the recieved DHCPv6 Advertise Message is failed
Summary: TAHI--DHCPv6--The check of IA options of the recieved DHCPv6 Advertise Messag...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcpv6
Version: 5.0
Hardware: All
OS: Linux
urgent
medium
Target Milestone: rc
: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 455668
TreeView+ depends on / blocked
 
Reported: 2007-11-04 08:01 UTC by Zhiyong Wu
Modified: 2009-01-20 21:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 21:38:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0165 normal SHIPPED_LIVE dhcpv6 bug fix update 2009-01-20 16:05:26 UTC

Description Zhiyong Wu 2007-11-04 08:01:01 UTC
Description of problem:

  When having dhcpv6 tests about "Advertise message in response to Solicit 

message with Multiple IA_NA Options" in the server mode,we found that the 

check of IA options of the recieved DHCPv6 Advertise Message is failed.

Version-Release number of selected component (if applicable):

  kernel-2.6.18-43.el5

Software Environment:   
  Testee(NUT):   
    RHEL5 
    Kernel:2.6.18-43.el5 
   
  Tester(TN):   
    FreeBSD6.2
    v6eval-3.0.12.tar.gz
   
TAHI package:    
  DHCPv6_Self_Test_P2_1_0_7.tar.gz

How reproducible:
  every time

Steps to Reproduce:    
  1. Configure TAHI test environment.     
  2. Run the TAHI test suite     
  3. After the test completes, check for the results 
  
Actual results:

   The check of IA options of the recieved DHCPv6 Advertise Message is failed.

Expected results:

   The check of IA options of the recieved DHCPv6 Advertise Message is not 

failed.

Additional info:
  
   please refer to
 
http://focus.brisbane.redhat.com/~zwu/dhcp_server/20071101/DHCPv6_Self_Test_P2_
1_0_7_server/rfc3315/index.html

   (1) 28 Part C : Advertise message in response to Solicit message with 
Multiple IA_NA Options

Comment 1 RHEL Product and Program Management 2007-11-07 10:24:35 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 David Cantrell 2008-01-16 04:50:13 UTC
This should be working dhcpv6-1.0.5.

Comment 4 Zhiyong Wu 2008-02-22 07:09:35 UTC
but the test cases FAIL on RHEL5.2 with dhcpv6-1.0.10

for more details, pls refer to

http://focus.brisbane.redhat.com/~zwu/RHEL5.2-Server-20080212.0/20080220/DHCPv6_Self_Test_P2_1_0_8_server_1.0.10/rfc3315/28.html

Comment 6 Denise Dumas 2008-02-27 15:30:44 UTC
In order to debug this problem, we need the test case for RHEL 5.2 with an exact
reproducer, including output with verbose debugging messages from the DHCPV6
software.  One way to do this would be to extract the commands that TAHI runs.
The man pages for dhcp6s, dhcp6r, and dhcp6c all show how to generate verbose
debug messages. 

Comment 8 David Cantrell 2008-03-12 20:16:20 UTC
Fixed in dhcpv6-1.0.10-2.el5.

Comment 14 Denise Dumas 2008-06-06 13:40:25 UTC
This is related to 365661, which is support for multiple IA_NA  options. 
Mitsuru and David have to change structs in the code to fix this  and we decided
that 5.3 is a better target for that (huge change, plus  time required). 

Comment 15 Red Hat Bugzilla 2008-07-08 01:24:21 UTC
Adding yshao@redhat.com to the cc list as the manager of the disabled user zwu@redhat.com who reported this bug

Comment 16 David Cantrell 2008-07-15 19:26:54 UTC

*** This bug has been marked as a duplicate of 439526 ***

Comment 17 David Cantrell 2008-07-15 23:24:11 UTC
A fix for this bug is in dhcpv6-1.0.10-6.el5 and later builds.

Comment 25 errata-xmlrpc 2009-01-20 21:38:16 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0165.html


Note You need to log in before you can comment on or make changes to this bug.