Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3639 - Bad commands in /etc/profile.d/kde.csh
Summary: Bad commands in /etc/profile.d/kde.csh
Keywords:
Status: CLOSED DUPLICATE of bug 3686
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdesupport
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-22 18:13 UTC by Kolar, Petr
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-29 15:44:56 UTC


Attachments (Terms of Use)

Description Kolar, Petr 1999-06-22 18:13:10 UTC
If a user has tcsh as her primary shell, the error message
would be displayed after login and some other bad things
would happen. The problem is in file /etc/profile.d/kde.csh,
where somebody forgot to change shell commands to csh
commands.

Following patch should fix the bug:


*** /etc/profile.d/kde.csh      Mon Jun 21 20:28:21 1999
--- /etc/profile.d/kde.csh.pk   Tue Jun 22 19:29:51 1999
***************
*** 5,13 ****
           endif
  endif
  setenv KDEDIR /usr
! kdepath="${KDEDIR}/bin"
! if ( echo ${PATH} | grep -q ${kdepath} ) then
!   exit
! endif
!
! setenv PATH "${kdepath}:${PATH}"
--- 5,10 ----
           endif
  endif
  setenv KDEDIR /usr
! set kdepath="${KDEDIR}/bin"
! echo ${PATH} | grep -q ${kdepath} || \
!   setenv PATH "${kdepath}:${PATH}"

Comment 1 Derek Tattersall 1999-06-29 15:44:59 UTC
*** This bug has been marked as a duplicate of 3686 ***


Note You need to log in before you can comment on or make changes to this bug.