Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 363101 - RHEL comps.xml files are not arch-specific
Summary: RHEL comps.xml files are not arch-specific
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: comps
Version: 5.1
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Dennis Gregorovic
QA Contact: Alexander Todorov
URL:
Whiteboard:
: 453723 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-02 00:04 UTC by Steve Siano
Modified: 2009-12-20 01:55 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-02 12:01:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2009:1400 normal SHIPPED_LIVE redhat-release bug fix and enhancement update 2009-09-01 12:04:54 UTC

Description Steve Siano 2007-11-02 00:04:11 UTC
Description of problem:
yum groupinfo 'Development Tools' lists the strace64 package as mandatory. 
However this package does not seem to be available from RHN.  Thus Development
Tools appears as an available group when running yum grouplist, even though all
of its mandatory packages, except strace64, are installed.  One of the mandatory
packages is strace, which is installed as 4.5.15-1.el5.x86_64.  So it appears
that strace64 should be removed from the list of mandatory packages.

Version-Release number of selected component (if applicable):
Linux <hostname> 2.6.18-8.1.15.el5 #1 SMP Thu Oct 4 04:06:39 EDT 2007 x86_64
x86_64 x86_64 GNU/Linux
yum 3.0.1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Dennis Gregorovic 2008-09-26 21:28:56 UTC
This is a side-effect of having the same comps.xml files across all RHEL 5 architectures.  On ppc, it makes sense for strace64 to be listed.  For other architectures, it doesn't make sense. This wouldn't be a trivial fix, but is something that we can look into.

Comment 4 Dennis Gregorovic 2009-02-05 16:55:54 UTC
*** Bug 453723 has been marked as a duplicate of this bug. ***

Comment 6 Dennis Gregorovic 2009-02-25 22:11:17 UTC
fix has been checked in such that RHEL 5.4 will have arch-specific comps.xml files and on each architecture the comps.xml package list will be filtered accordingly.

Comment 8 Dennis Gregorovic 2009-06-15 15:10:10 UTC
*** Bug 278621 has been marked as a duplicate of this bug. ***

Comment 9 Dennis Gregorovic 2009-06-15 15:11:20 UTC
Moving back to assigned since etherboot is showing up in ia64 comps.xml even though etherboot packages don't exist on that architecture.

Comment 10 Dennis Gregorovic 2009-06-15 20:05:36 UTC
I was able to track down the cause of the problem.  The fix will be in tomorrow's nightly tree.

Comment 12 Alexander Todorov 2009-06-19 11:49:04 UTC
$ pwd
/mnt/redhat/nightly/RHEL5.4-Server-20090619.nightly/5

$ grep strace64 ./*/os/*/repodata/comps*
./ppc/os/Server/repodata/comps-rhel5-server-core.xml:      <packagereq type='mandatory'>strace64</packagereq>

$ grep etherboot ./*/os/*/repodata/comps*
./i386/os/VT/repodata/comps-rhel5-vt.xml:      <packagereq type='mandatory'>etherboot-zroms</packagereq>
./i386/os/VT/repodata/comps-rhel5-vt.xml:      <packagereq type='mandatory'>etherboot-zroms-kvm</packagereq>
./i386/os/VT/repodata/comps-rhel5-vt.xml:      <packagereq type='optional'>etherboot-pxes</packagereq>
./i386/os/VT/repodata/comps-rhel5-vt.xml:      <packagereq type='optional'>etherboot-roms</packagereq>
./i386/os/VT/repodata/comps-rhel5-vt.xml:      <packagereq type='optional'>etherboot-roms-kvm</packagereq>
./x86_64/os/VT/repodata/comps-rhel5-vt.xml:      <packagereq type='mandatory'>etherboot-zroms</packagereq>
./x86_64/os/VT/repodata/comps-rhel5-vt.xml:      <packagereq type='mandatory'>etherboot-zroms-kvm</packagereq>
./x86_64/os/VT/repodata/comps-rhel5-vt.xml:      <packagereq type='optional'>etherboot-pxes</packagereq>
./x86_64/os/VT/repodata/comps-rhel5-vt.xml:      <packagereq type='optional'>etherboot-roms</packagereq>
./x86_64/os/VT/repodata/comps-rhel5-vt.xml:      <packagereq type='optional'>etherboot-roms-kvm</packagereq>

$ grep systemz ./*/os/*/repodata/comps*
./s390x/os/Server/repodata/comps-rhel5-server-core.xml:    <id>systemz-tools</id>

Moving to VERIFIED. Package strace64 (used to report the bug) is in ppc comps only, etherboot packages (comment #9) are i386 and x86_64 only and systemz-tools group is s390x only. This shows comps.xml is now arch specific.

Comment 14 errata-xmlrpc 2009-09-02 12:01:51 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1400.html


Note You need to log in before you can comment on or make changes to this bug.