Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3589 - Installation nightmare
Summary: Installation nightmare
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-19 02:23 UTC by cadaver
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-10 20:52:09 UTC


Attachments (Terms of Use)

Description cadaver 1999-06-19 02:23:26 UTC
Nightmare installing Linux RedHat 6.0 ( lrh6 )

I use a 486 System, with a 4.2 Gb Ide disk and my partirion
table
looks as follows:

NTFS ~ 3Gb | Linux primary ~ 1Gb | Linux Swap ~ 80Mb | Dos

All four partitions was primary. I began the linux
installation,
using the cd method. First I used the 'workstation' option.
Then I used
'custom' option because the 'workstation' doesn't gives the
possibility
to (de)select packages. The installation ended a couple of
times with
the message 'not enough space on the destionation drive' -
a horror.
After quick look at the consoles and a couple of new tries
I was
astonished - obviously the setup tries to install the
packages on the
swap partition!!! Irestarted, deleted the partion and
creted them again -
nothing new. After a couple of tries I was convinced that
both fdisk and
disk druid are creating extended partitions. Fdisk didn't
ask for the type
of partition. This impressed me and after a little
hesitation I backuped
the fourth ( dos ) partition and deleted it. This time the
installation
succedes...
	Obviously, the problem is in both fdisk and disk
druid - they can't
successfully update the partition table by such a
configuration:

disk | free space | disk

but this is a software error, isn't it?

After installing all the packages I setup all of the system
and - ...
a lilo problem. By successful installation I have used the
disk druid
and now I have following disk configuration:

ntfs | extended ( linux primary, linux swap, dos ).

Why doesn't disk druid asks what type of partition to
create - primary or
extended?????????????

Neither installing lilo in the boot sector of the extended
partition
( as described by docs ) nor in the boot sector of the
linux primary
partition works. By intsalling it in the boot sector of
extended partition
it dies LIL-. The documantation doesn't helps much. To
install lilo in
MBR wasn't an option. So - I started the installation
again, deleted all
partitions except the ntfs one and use the fdisk to create
four primary
partitions. This was all. Now I have a couple a questions:
	1) I am using linux since years and I really think
rh is the one of the
best distributions, but why there isn't a way to install
the system
having a lot of more control over the installation process
( even in
console mode, as in the old versions ). Having a good
installation
program is very important for users too. I could imagine
what a user
installing linux for first time would do in my position -
the cd out
through the window... I have installed Windows ( all ) a
houndred:) of
times and I never had such a problem. The installation must
works in
every situation...
	2) What's the problem with the disks? Only a fdisk
and disk druid bug?
	3) The documentation states that lilo could boot
from extended
partition. I didn't succeed. Is it possible and how. The
documentation is
written not for a user. It gives the configuration but
didn't explorers
the problemswith examples. This isn't the appropriate way
of writting
user documentation but If I had had rh printed manuals, I
would know :)

Best regards
Cadaver

PS: Maybe is too long for a bugtrack:) Excuse me!


Note You need to log in before you can comment on or make changes to this bug.