Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3568 - RHSA: NFS root squashing broken with 32 bit uid_t
Summary: RHSA: NFS root squashing broken with 32 bit uid_t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-server
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-18 12:01 UTC by Jeff Johnson
Modified: 2015-01-07 23:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-23 08:25:51 UTC


Attachments (Terms of Use)

Description Jeff Johnson 1999-06-18 12:01:03 UTC
It's that time of the year again...
Someone just mailed me about a problem he was having with
unfsd, and
in passing he mentioned that Linux refuses setfsuid(-2).

Unfortunately, unfsd relies on this for root squashing
(unless you've
defined a different anon uid/gid).

The cause of the problem is glibc's move to 32 bit uid_t,
while the kernel remains at 16 bit.  To compensate for this,
the
glibc setfsuid() implementation has some hideously `clever'
code
(sysdeps/unix/sysv/linux/i386/setfsuid.c):

int
setfsuid (uid_t uid)
{
  if (uid != (uid_t) ((__kernel_uid_t) uid))
    {
      __set_errno (EINVAL);
      return -1;
    }

  return INLINE_SYSCALL (setfsuid, 1, uid);
}

It is entirely possible that other applications are affected
by these
symptoms as well, because seteuid exhibits the same
properties.

A patched unfsd (2.2.beta44) will be available shortly from
ftp://linux.mathematik.tu-darmstadt.de/pub/linux/people/okir

Comment 1 Jeff Johnson 1999-06-18 12:19:59 UTC
Jay, this 5.2 errata package needs QA:
	5.2.2:	nfs-server-2.2beta44-1


Note You need to log in before you can comment on or make changes to this bug.