Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3562 - Wrong pseudo tty modes
Summary: Wrong pseudo tty modes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: screen
Version: 6.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-18 09:04 UTC by David Balažic
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-18 15:18:47 UTC


Attachments (Terms of Use)

Description David Balažic 1999-06-18 09:04:22 UTC
screen-3.7.6-6 set the pseudo tty perms and owner/group incorrectly.
By default it sets it to mode 622 user : user , group : user
that is for user stein it is set to :
crw--w--w-   1 stein    stein    136,   5 Jun 18 10:59 5
But logging in via ssh and telnet set it to :
crw--w----   1 stein    tty    136,   4 Jun 18 10:59 4

Comment 1 David Balažic 1999-06-18 10:49:59 UTC
I noticed in the original screen 3.7.6 sources that it sets the
group of PTY to PTYGROUP, if symbol PTYGROUP is defined.
I executed configure and it DID set PTYGROUP to 5, which is correct.
I compiled it and it works sorta good. Set tty ownership correctly,
but uses ttya0 and not pts/1 :-)

Comment 2 David Balažic 1999-06-18 14:45:59 UTC
Seem to be fixed after installing screen-3.7.6-9 and dev-2.7.7-2.

Comment 3 Bill Nottingham 1999-06-18 15:18:59 UTC
yup, this was part of the errata fix.


Note You need to log in before you can comment on or make changes to this bug.