Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 356 - WindowMaker+AnotherLevel requires EGCS, doesn't use M4
Summary: WindowMaker+AnotherLevel requires EGCS, doesn't use M4
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: WindowMaker
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 936 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-08 20:18 UTC by Steve Coile
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-16 21:45:11 UTC


Attachments (Terms of Use)

Description Steve Coile 1998-12-08 20:18:50 UTC
AnotherLevel, when used with WindowMaker, is unable to
generate the Programs desktop popup menu because WindowMaker
uses /lib/cpp rather than m4 (m4 is used by FVWM2) to do
configuration file macro expansion.  /lib/cpp is a component
of EGCS.  WindowMaker should be built to use M4 if at all
possible.

Comment 1 Steve Coile 1998-12-08 20:23:59 UTC
To clarify, AnotherLevel will not generate the Programs popup menu if
run with WindowMaker ON A SYSTEM THAT DOESN'T HAVE EGCS INSTALLED.

Comment 2 Aleksey Nogin 1998-12-09 09:20:59 UTC
Also, ~/.Xdefaults is parsed using cpp. A while ago there was an idea
to put cpp into a separate RPM and add a "Requires: cpp" to all the
packages that use cpp

Comment 3 David Lawrence 1998-12-11 18:11:59 UTC
This has been verified to be a bug. If EGCS is not installed wmconfig
menus do not work properly in WindowMaker.

Comment 4 Cristian Gafton 1999-01-14 07:13:59 UTC
This should be fixed in the next release of Red Hat Linux. Source RPMs
should be available with the next RawHide release.

Comment 5 Jeff Johnson 1999-05-16 21:45:59 UTC
*** Bug 936 has been marked as a duplicate of this bug. ***

I installed RedHat 5.2 with the XFree86 component but
without the Development component.  xrdb fails because
it can't find /lib/cpp.

I think the best solution is to make a "cpp" rpm that
contains /lib/cpp as an actual file (instead of a symlink)
and make the packages with xrdb and imake require the cpp
rpm.


------- Additional Comments From jbj@redhat.com  01/24/99 14:10 -------
This has been done in Raw Hide. Here's the package list for cpp

rpm -qlp /D/6.0/i386/cpp-1.1.1-7.i386.rpm
/lib/cpp
/usr/info/cpp.info.gz
/usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.60.1/cpp
/usr/man/man1/cccp.1
/usr/man/man1/cpp.1


------- Additional Comments From ayn2@cornell.edu  01/25/99 22:36 -------
This is a duplicate of #354

------- Additional Comments From ayn2@cornell.edu  01/25/99 22:36 -------
Sorry, #356


Note You need to log in before you can comment on or make changes to this bug.