Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3524 - xinitrc-2.4-1 puts wrong permissions on /etc/X11/xinit/*
Summary: xinitrc-2.4-1 puts wrong permissions on /etc/X11/xinit/*
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinitrc
Version: 6.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
: 3537 3543 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-17 10:57 UTC by Tony Kocurko
Modified: 2015-01-07 23:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-17 18:42:59 UTC


Attachments (Terms of Use)

Description Tony Kocurko 1999-06-17 10:57:33 UTC
At least /etc/X11/xinit/Xclients had 0644 permissions rather
than 0755, after I installed the xinitrc-2.4-1.noarch.rpm
upgrade as suggested on your 6.0 Errata page.

Otherwise, everything went in perfectly. You guys are great!

Comment 1 Bill Nottingham 1999-06-17 18:39:59 UTC
*** Bug 3537 has been marked as a duplicate of this bug. ***

When I installed the new xinitrc package for RH 6.0, the
Xclients file in /etc/X11/xinitrc does not have execute
permissions.  This did not allow me to start up with
enlightement or KDE...  Just twm

chmod a+rx fixes the problem

Comment 2 Bill Nottingham 1999-06-17 18:42:59 UTC
fixed in xinitrc-2.4.1-1, which will be available shortly.
Oooooooooooops.

Comment 3 Bill Nottingham 1999-06-17 22:21:59 UTC
*** Bug 3543 has been marked as a duplicate of this bug. ***

The new xinitrc version 2.4.1_noarch for the 386 Intel
platform doesn't work at all. After upgrade of the necesary
XFree86 packages errata.Trying startx at root give permision
denied /etc/X11/xinit/Xclients.

Reinstalling the old xinitrc-2_3.1_noarch.rpm correct the
problem.

My by a misconfiguration in the source of xinitrc


Note You need to log in before you can comment on or make changes to this bug.