Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 348 - Erratic response from modem
Summary: Erratic response from modem
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: minicom
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-08 14:23 UTC by tacedi
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-12-29 20:26:10 UTC


Attachments (Terms of Use)

Description tacedi 1998-12-08 14:23:01 UTC
Hi,

I'm trying to get a fax modem working with efax under Redhat
5.2 without success.   I think the problem is that the modem
is not sending responses back to the efax software.

When I try to use minicom to test the connection, I
initially get no echo of commands.   I still get no echo
when I issue "ATE1".  When I use ctrl-a z, and select the
option to toggle local Echo on/off, I then see commands
echoed; however, there is no OK response.

The strange thing is that if I do nothing for about 10
minutes, then type AT,  I suddenly get double echo, e.g.,
"atat", followed by the OK prompt.   If I then toggle local
Echo on/off, everything seems to work ok.

If, instead of using minicom, I do "cu -l /dev/modem", I get
"Connected", but I cannot get an "OK" response from the
modem, nor do I see my commands echoed back to the terminal
even though I issued ATE1 (echo keyboard input).

Using either minicom or cu, I can dial another phone number
(e.g., "ATDT[number]") in my office and get a ring, even
though I never get any responses from the modem.

I've tried two different modems with the same results.  I am
using the same cable I used with the modem when I was
running Win95.


Any ideas would be appreciated.

Willis Gregory
tacedi@series2000.com

Comment 1 Aleksey Nogin 1998-12-09 00:54:59 UTC
You may want to install the setserial RPM and use the setserial
program to make sure you are using the right IRQ number.

Comment 2 David Lawrence 1998-12-29 20:26:59 UTC
This is a modem configuration issue. We were unable to replicate it in
the test lab.


Note You need to log in before you can comment on or make changes to this bug.