Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3476 - amd -F dumps core
Summary: amd -F dumps core
Keywords:
Status: CLOSED DUPLICATE of bug 2443
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: am-utils
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-15 14:33 UTC by Cristian Gafton
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-15 15:00:11 UTC


Attachments (Terms of Use)

Description Cristian Gafton 1999-06-15 14:33:39 UTC
I have hit a (show-stopper) problem with am-utils-6.0-3
under
redhat 6.0 (this is after a clean "everything" install). If
you try to use the -F option - which allows you to point to
an
external configuration file - amd promptly dumps core (some
amd options I use in our machines are only accessible from
the
configuration file as opposed to command line switches).

The core dump appears to be related to an fprintf to stderr
that's processed when the configuration is parsed from the
command line and the "-F" flag is found. A message is
supposed
to be printed to stderr but instead the whole thing core
dumps. Commenting out the offending line and rebuilding the
whole package is the workaround I'm currently using. This
might be a problem with the underlying glibc2.1...

Comment 1 Jeff Johnson 1999-06-15 15:00:59 UTC
*** This bug has been marked as a duplicate of 2443 ***


Note You need to log in before you can comment on or make changes to this bug.