Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3463 - egcs source RPM contains binaries!! GPL violation?
Summary: egcs source RPM contains binaries!! GPL violation?
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: egcs
Version: 6.0
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-14 19:08 UTC by Chris Evans
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-02 21:37:18 UTC


Attachments (Terms of Use)

Description Chris Evans 1999-06-14 19:08:25 UTC
Hi

egcs source RPM contains a .tar.gz of binaries of old
compatability libraries. Including libg++-2.7.2.

My concern isn't really the GPL violation, but more the fact
I couldn't debug a f****** irritating bug by building a
debug library from SRPM. I will log a separate bug about
this.

Chris

Comment 1 Jay Turner 1999-06-30 13:34:59 UTC
This issue has been forwarded to a developer for further action.

Comment 2 Cristian Gafton 1999-07-02 21:17:59 UTC
I am not sure what the bug is about. the binaries in the srpm have
nothing to do with building a debugging library.

Comment 3 Chris Evans 1999-07-02 21:33:59 UTC
Sorry if I wasn't clear.
The issue is this: there is a bug in the library itself. I want to
step through the library and fix the bug. I can't because you have
shipped some GPL code with binaries only and no source.

Comment 4 Cristian Gafton 1999-07-02 21:37:59 UTC
The source code for the library that is the default on the system is
included. You can not recompile the older libstdc++ libraries with the
new compilers, so including the source code for that would do you
absolutely no good.

Why don't you debug the application against the libbstdc++ 2.9? All of
the previous versions should be considered evil and bad.


Note You need to log in before you can comment on or make changes to this bug.