Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3459 - vi and vim don't work in vc #2 during install due to missing libX11.so.6
Summary: vi and vim don't work in vc #2 during install due to missing libX11.so.6
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL: http://pobox.com/~e.maryniak/
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-14 17:46 UTC by Eric Maryniak
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-15 11:26:49 UTC


Attachments (Terms of Use)

Description Eric Maryniak 1999-06-14 17:46:57 UTC
When booting with the Red Hat floppy, you can use,
after some menus, virtual console 2 with Alt-F2,
where you have a bash prompt:  bash#
Listed in /bin are some programs (not much), amongst
others vi and vim. However, when you call vi or vim,
you get this error:

"vi: error in loading shared libraries: libX11.so.6:
 cannot open shared object: No such file or directory"

This is somewhat awkward, as I wanted to edit a file
on the Win98 (vfat) partition, namely a log file of
what I was doing :-)
Note that I was able to mount it:
  /bin/insmod fat.o
  /bin/insmod vfat.o
  mkdir /dos
  mount -t vfat /dev/hda1 /dos
I also was not able to run 'more' (or 'less') and gpm
at installation time.
My idea was to keep a log of what I was doing and
copy it with gpm, so I would not have to write it on
paper and type it in again, should I need to install
again (which I did :-)

Comment 1 Jeff Johnson 1999-06-14 17:58:59 UTC
*** This bug has been marked as a duplicate of 2262 ***

Comment 2 Jeff Johnson 1999-06-15 11:26:59 UTC
Ooops, #2262 was the wrong bug. Here's the right one.

*** This bug has been marked as a duplicate of 2439 ***


Note You need to log in before you can comment on or make changes to this bug.