Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3437 - Some newer printers not supported by ghostscript (i.e., HP Deskjet 890C)
Summary: Some newer printers not supported by ghostscript (i.e., HP Deskjet 890C)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ghostscript
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-13 20:12 UTC by Edward Kuns
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-29 16:03:30 UTC


Attachments (Terms of Use)

Description Edward Kuns 1999-06-13 20:12:41 UTC
Drivers exist for a number of newer printers that are not
included with Red Hat 6.0 (or earlier).  I spent an
afternoon figuring out how to recompile ghostscript
including the hpdj and cdj850 modules.  I'm willing to work
with someone inside Red Hat to get these included in Red Hat
updates, since it will be a long time before either is
officially supported by ghostscript.  (cdj850 is apparently
included in ghostscript after the 5.50 release.)

I didn't use RPM to compile these modules but am willing to
learn how to modify a spec file to do so.  I thought I would
post here before I did so.

Comment 1 Jeff Johnson 1999-06-13 20:39:59 UTC
Because of the ghostscript license, we can only ship the
previous release of ghostscript, so newer printers are often
not included. If you have a contributed driver that we can include
in ghostscript, then attach to this message. Otherwise, grab
a newer ghostscript package or wait for a new release of ghostscript
so that we can upgrade.

Comment 2 Edward Kuns 1999-06-15 05:52:59 UTC
Right.  Of the two ghostscript modules I use for my printer, one still
isn't part of ghostscript as of 5.50 and the other will be for
whatever version is released after 5.50.

The two contributed drivers I was hoping Red Hat could include in
future ghostscript releases can be found at:

hpdj version 2.5

ftp://ftp.pdb.sni.de/pub/utilities/misc/hpdj.html

hp850c version 1.3  (The beta test 1.4 version will not compile with
ghostscript 5.10 without changes because it is intended for gs5.50 and
beyond.)

http://www.erdw.ethz.ch/~bonk/hp850/hp850.html

Let me know if you need any more information than this and if there is
anything else I can do to help.

Comment 3 Michael K. Johnson 1999-07-29 14:25:59 UTC
The hp8xxs13 driver from www.erdw.ethz.ch is in as of 5.10-8

Comment 4 Michael K. Johnson 1999-07-29 16:03:59 UTC
5.10-9 includes hpdj driver and should be in the next rawhide release.


Note You need to log in before you can comment on or make changes to this bug.