Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3436 - gmc gets corrupt info from RPM files
Summary: gmc gets corrupt info from RPM files
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gmc
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-13 20:05 UTC by Edward Kuns
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-16 15:29:50 UTC


Attachments (Terms of Use)

Description Edward Kuns 1999-06-13 20:05:51 UTC
Entering this bug, I didn't see a "gmc" component so I put
this under "gnome".

In gmc-4.5.30-12 when I view an RPM file's contents, all
seems well until I double click on any file inside the RPM.
After that, gmc seems to be very confused about what
filesnames are in the rpm, getting junk names.  In addition,
it fails to open files, saying "file not found".

If I close gmc and start it up again and never double-click
on anything, it seems to work better.  ie, if I always use
the right-button followed by "view".

Also, gmc doesn't clean up after itself in /tmp.  It leaves
many many "ext2s*" and "file*" files in /tmp.

Comment 1 Jay Turner 1999-06-14 17:37:59 UTC
Both of these issues were verified in the test lab.

Comment 2 Elliot Lee 1999-08-03 20:14:59 UTC
I can't reproduce part 1 using gmc from CVS today, but the VFS timeout
doesn't seem to be removing files correctly, so part 2 remains.

Comment 3 Preston Brown 2000-02-16 15:29:59 UTC
Elliot:

 Do the temporary files littering /tmp persist in gmc from the forthcoming 6.2
 release?Elliot:

Do the temporary files littering /tmp persist in gmc from the forthcoming 6.2
release?


Note You need to log in before you can comment on or make changes to this bug.