Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3416 - Zip drive read/write errors
Summary: Zip drive read/write errors
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL: peter.evans@brunel.ac.uk
Whiteboard:
: 3043 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-12 16:04 UTC by peter.evans
Modified: 2008-05-01 15:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-07 12:30:02 UTC


Attachments (Terms of Use)

Description peter.evans 1999-06-12 16:04:24 UTC
686 based system. 128Mb ram. ATAPI zip drive gives I/O error
every 128th sector, esp. during write. Happens with
ATAPI_FLOPPY support as module and compiled into kernel

Comment 1 Jeff Johnson 1999-06-14 18:09:59 UTC
*** Bug 3043 has been marked as a duplicate of this bug. ***

ATAPI internal zip drives do not mount correctly.  Mine is
recognized as hdd.  I set up the fstab for:

/dev/hdd4	/mnt/zip	vfat	noauto,rw	0 0

When I mount it, it mounts fine.  When I read or copy from a
zip disk, no problems.  BUT, when I write to a zip disk it
corrupts the file and it is unusable.  This did not occur in
version 5.2.  Please help - I have made the jump to Linux
because of RedHat (since version 5.0) and now I find I have
to go back to my old Windows machine to write to my zip
disks.  HELP!

-Mike Dill

------- Additional Comments From dkl@redhat.com  05/28/99 16:48 -------
I was able to replicate this problem in our test lab using an internal
ATAPI zip drive. Whenever a write operation is done using kernel
2.2.5-15, a hdd I/O error message is printed several times to the
screen. Although the write operation seems to complete well enough, it
is probably not reliable.

Comment 2 thibaut.cousin 1999-08-17 12:42:59 UTC
The problem is solved by upgrading to kernel 2.2.11 (it is a known
bug).

Comment 3 Bill Nottingham 1999-08-25 22:42:59 UTC
This is fixed in the 2.2.11 kernel in Raw Hide.

Comment 4 Cristian Gafton 1999-09-07 12:29:59 UTC
Workaround provided by madill@inreach.com:

Just a short note to let you know I have learned a different way to
solve the Zip drive problem - one which you might want to share with
others having this trouble.

I used  -   insmod ide-scsi  -  to install the ATAPI / SCSI emulation
module to the kernel.  It now sets up the Zip as sda4 - a scsi device.

It reads fine - writes fine - works great and fast.


Note You need to log in before you can comment on or make changes to this bug.