Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3400 - can't add static routes via aliased interface
Summary: can't add static routes via aliased interface
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-11 00:53 UTC by cliff
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-14 21:39:13 UTC


Attachments (Terms of Use)

Description cliff 1999-06-11 00:53:01 UTC
If you add a static route via an aliased address on an
ethernet card, at least for non-linuxconf aliases and
static routes added via control-panel, it will never get
added.

The problem is in /etc/sysconfig/network-scripts/ifup-post

/etc/sysconfig/network-scripts/ifup-routes ${DEVICE}

if [ "$ISALIAS" = no ] ; then
    /etc/sysconfig/network-scripts/ifup-aliases ${DEVICE}
fi

Routes are added, then aliases brought up.  Moving the
ifup-routes command after the ifup-aliases seems to
fix the problem without any negative effects.

Cliff

Comment 1 Jay Turner 1999-06-14 18:03:59 UTC
This issue has been forwarded to a developer for further action.

Comment 2 Bill Nottingham 1999-06-14 21:39:59 UTC
fixed in initscripts > 4.20


Note You need to log in before you can comment on or make changes to this bug.